11G OCM Install OEM 10.2.0.1 (3)


Continuing my saga of installing 11G OCM Install OEM 10.2.0.1, I found the Oracle Support document called How to Install Grid Control 10.2.0.5.0 on OEL/RHEL5/SLES10 Using the Existing Database (11g) Option [ID 784963.1].

Somethings I wonder how the simplest things escape me.

I have created the following response file (comments and blank lines have been stripped, and passwords have been suppressed) for installing OEM 10.2.0.1:

RESPONSEFILE_VERSION=2.2.1.0.0
UNIX_GROUP_NAME="oinstall"
FROM_LOCATION="/opt/oracle/software/Linux_Grid_Control_full_102010/oms/Disk1/stage/products.xml"
FROM_LOCATION_CD_LABEL="EM10g"
BASEDIR="/opt/oracle/app"
INSTALLATION_NAME=OMS_HOME1
NEXT_SESSION=false
NEXT_SESSION_ON_FAIL=false
DEINSTALL_LIST={"oracle.sysman.top.oms","10.2.0.1.0"}
SHOW_DEINSTALL_CONFIRMATION=true
SHOW_DEINSTALL_PROGRESS=true
REMOVE_HOMES=
ACCEPT_LICENSE_AGREEMENT=true
TOPLEVEL_COMPONENT={"oracle.sysman.top.oms","10.2.0.1.0"}
COMPONENT_LANGUAGES={"en"}
s_reposHost="gridctrl.yaocm.id.au"
s_reposPort="1521"
s_reposSID="repos"
s_reposDBAPwd="********"
s_mgmtTbsName="/opt/oracle/app/oradata/repos/mgmt.dbf"
s_ecmTbsName="/opt/oracle/app/oradata/repos/mgmt_ecm_depot1.dbf"
b_emailSelected=false
s_emailAddress=
s_emailServer=
b_metalinkSelected=false
s_metalinkUser=
s_metalinkPassword=
b_proxySelected=false
EM_PROXYUSER=
EM_PROXYREALM=
EM_PROXYPASSWORD=
EM_PROXYHOST=
EM_DONTPROXYFOR=
EM_PROXYPORT=
s_securePassword="********"
s_securePasswordConfirm="********"
b_lockedSelected=true
s_reposPwd="********"
s_reposPwdConfirm="********"
n_firstInstanceValidation=2
n_firstReposValidation=1
n_firstReposPwdValidation=2
n_firstSecureValidation=2
n_firstVldnEmailSer=2
b_upgrade=false
b_showOptConfigPage=TRUE
s_installType="NOSEED"

The higlighted lines are the values I changed to match the values specified in 11G OCM Install OEM 10.2.0.1 and 11G OCM Install OEM 10.2.0.1 (2).

I then used the following command to do the installation:

/opt/oracle/software/Linux_Grid_Control_full_102010/runInstaller -noconfig -ignoreSysPrereqs -silent -responseFile /home/oracle/em_using_existing_db.rsp use_prereq_checker=false b_skipDBValidation=true -force

Unfortunately, I got the following error because I did not read the Metalink document carefully:

/opt/oracle/app/oms10g/Apache/Apache/bin/httpd: error while loading shared libraries: libdb.so.2: cannot open shared object file: No such file or directory
Advertisements

One thought on “11G OCM Install OEM 10.2.0.1 (3)

  1. 11G OCM Install OEM 10.2.0.1 (4) « Yet Another OCM

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s